Scheduled Maintenance
Resolved·Full outage

Service has been fully restored.

All features are operating as expected. We apologize for the inconvenience caused.

Tue, Jun 24, 2025, 02:41 PM
(6 days ago)
·
Affected components
Taurin Application
Integrations
Updates

Resolved

Service has been fully restored.

All features are operating as expected. We apologize for the inconvenience caused.

Tue, Jun 24, 2025, 02:41 PM

Identified

Current status: Maintenance still in progress

Original window: 2:00 PM – 5:00 PM (UTC+0)

Revised target completion: June 24  3:00 PM (UTC+0)

🔄 Why the delay?

A last-minute issue surfaced during the deployment tests. We’re applying a fix and re-running our validation suite to ensure stability before reopening the service.

🚦 Impact

The service will remain intermittently unavailable until the work is complete. All user data remains safe.

We’re sorry for the extended downtime and appreciate your patience.

Sat, Jun 21, 2025, 02:08 PM(3 days earlier)